Yongchan Hong

    Yongchan Hong

    7 months ago
    Can anyone help me with flytectl? I am new to flyte and I just deployed flyte sandbox using helm on AWS EKS with ingress. I am wondering how to configure flytectl - especially host part.
    Yongchan Hong

    Yongchan Hong

    7 months ago
    Thank you so much! So is flyte endpoint something like *.amazonaws.com ? I tried to register and it showed up error message like following:
    Example 0xc000bf5ea0 failed to register rpc error: code = Unavailable desc = transport is closing
    Ketan (kumare3)

    Ketan (kumare3)

    7 months ago
    @Yongchan Hong it has to be publicly accessible and you need to add <dns😕//|dns:///> as the prefix
    Are u using some Ingress controller
    Yongchan Hong

    Yongchan Hong

    7 months ago
    hmm so can address like flyte-dev.xtrm-data.io work? Or should it be specific elb address like that
    Ketan (kumare3)

    Ketan (kumare3)

    7 months ago
    Yes it can
    Yongchan Hong

    Yongchan Hong

    7 months ago
    I am using nginx ingress controller
    y

    Yuvraj

    7 months ago
    kubectl get ingress -n flyte
    will return you exact ingress address that you can use for flytectl
    Yongchan Hong

    Yongchan Hong

    7 months ago
    admin:
      # For GRPC endpoints you might want to use dns:///flyte.myexample.com
      endpoint: dns:///***.<http://amazonaws.com|amazonaws.com>
      insecureSkipVerify: true
      insecure: true
    logger:
      show-source: true
      level: 0
    I tried both **.amazonaws.com and flyte-dev.xtrm-data.io, and both gives me Unavailable desc = transport is closing error. Btw Web UI works. Is anything wrong with my config file? And I used kubectl to get exact ingress address
    Sorry for bothering everyone🙇🏽
    Ketan (kumare3)

    Ketan (kumare3)

    7 months ago
    @Yongchan Hong no worries at all. We are sorry that you are having problems installing. Did you try what Yuvraj suggested
    y

    Yuvraj

    7 months ago
    Why do you have
    insecure:true
    ? Are you using insecure ingress ?
    Yongchan Hong

    Yongchan Hong

    7 months ago
    Ah that was the problem. It works after erasing
    insecure:true
    Thank you so much for your help!
    Ketan (kumare3)

    Ketan (kumare3)

    7 months ago
    @Yongchan Hong can you propose a doc update?
    Yongchan Hong

    Yongchan Hong

    7 months ago
    Sure 🙏 Thank you!!