https://flyte.org logo
#ask-the-community
Title
# ask-the-community
c

Chandramoulee K V

10/14/2022, 5:39 AM
Hi, I have a private ECR image and i tried binding it to a task and register the workflow . It worked and now the task is binded with the private ECR image but when i run the workflow i get this following error:
containers with unready status: [a4tbv4qblclb2d8kdqg6-n1-0]|Back-off pulling image {ECR IMAGE}
What all accesses should be provided to the ECR image? Any idea on this
c

Chandramoulee K V

10/21/2022, 8:55 AM
Hi @Samhita Alla Yes i have checked the documentation and after adding the imagePullSecrets to the default service account under the flyte namespace. I tired to register a workflow with a private ECR image to check if its working and it is giving me this error
Copy code
[1/1] currentAttempt done. Last Error: USER::Pod failed. No message received from kubernetes.
[arzkgjxlxlcglwl9dh75-n0-0] terminated with exit code (1). Reason [Error]. Message: 
tail: unrecognized option '--additional-distribution'
Try 'tail --help' for more information.
Can you look into this?
s

Samhita Alla

10/21/2022, 10:08 AM
Could you send the task details? It should be present after you click the task and select the task tab on the UI.
71 Views