https://flyte.org logo
#announcements
Title
# announcements
j

jeev

02/02/2022, 5:56 PM
Is there a default task timeout? Does it happen to be 48 hours by some chance? Is it configurable?
@Greg Gydush
k

Ketan (kumare3)

02/02/2022, 6:40 PM
yes there is
it is 48 hours, you need to change the config
i think we should change the default to unlimited, cc @Kenny Workman
@jeev you need to set this -
Copy code
core.yaml: |
    propeller:
      downstream-eval-duration: 30s
      enable-admin-launcher: true
      gc-interval: 12h
      node-config:
        default-deadlines:
          node-execution-deadline: 240h0m0s
          node-active-deadline: 240h0m0s
          workflow-active-deadline: 240h0m0s
🙏 1
and can you file an issue for unlimited as the default?
j

jeev

02/02/2022, 6:56 PM
awesome thanks @Ketan (kumare3)
@Greg Gydush: fyi!
also @Jay Ganbat
k

Ketan (kumare3)

02/02/2022, 7:02 PM
are you filing an issue?
j

jeev

02/02/2022, 7:02 PM
we will
k

Kenny Workman

02/02/2022, 8:12 PM
from my perspective / latch’s use case, default of unlimited is definitely expected so the timeout was unexpected
so +1
👍 1
97 Views