Trying to resolve flytekit 1.2.7 with python 3.7 u...
# ask-the-community
k
Trying to resolve flytekit 1.2.7 with python 3.7 using mamba, I am told, that flytekit requires >=3.8, while looking at the flytekit repository, in the setup.py, the minimum required version is specified as 3.7 (which also works with pip). Does anyone have an idea, how to install flytekit 1.2.7 using mamba? The environment.yml contains the following:
Copy code
channels:
  - conda-forge
dependencies:
  - python =3.7
  - flytekit==1.2.7
The error message looks like that:
Copy code
conda-forge/linux-64                                        Using cache                                                 
conda-forge/noarch                                          Using cache                                                 
error    libmamba Could not solve for environment specs                                                                     
Encountered problems while solving:                                                                                       
- package flytekit-1.2.7-pyhd8ed1ab_0 requires python >=3.8, but none of the providers can be installed                                                                                                                                       The environment can't be solved, aborting the operation                                                                                                                                                                                     critical libmamba Could not solve for environment specs
b
I think you won’t be able to. Please note that
conda
packages are a thin wrapper around PyPI packages, which mostly swap out the PyPI dependencies for dependencies on
conda-forge
(this is a strong simplification, but should do in the case of
flytekit
) This re-packaging is done in what’s called a feedstock (for packages on
conda-forge
). In particular you can find the
flytekit-feedstock
here. When you checkout the recipe (called `meta.yaml`; the equivalent of a
setup.py
or
pyproject.toml
in the
conda
world), you can see that for some reason, the conda package only allows
python>=3.8
here
n
the reason there is python3.7 would have required architecture specific requirements, which the conda recipe does not currently support. Since 3.7 is being EOL’d this June we decided not to go that direction. @Klemens Kasseroller are you restricted to python 3.7?
k
Thanks for the replies and the explanation @Bernhard Stadlbauer. @Niels Bantilan I was trying to add flytekit to an existing environment with python 3.7 and was surprised, that the solver complained about flytkit not being compatible with python 3.7. I updated a few dependencies incl. python in my environment and everything works fine now.
124 Views