https://flyte.org logo
#ask-the-community
Title
# ask-the-community
j

Jay Phan

02/08/2023, 7:17 AM
Have anyone try the https://docs.flyte.org/projects/cookbook/en/latest/bioinformatics_examples.html Bioinformatics Tutorial, I was able to run it locally but when I run it on Flyte cluster it failed with this message:
Copy code
Traceback (most recent call last):

      File "/usr/local/lib/python3.10/site-packages/flytekit/exceptions/scopes.py", line 165, in system_entry_point
        return wrapped(*args, **kwargs)
      File "/usr/local/lib/python3.10/site-packages/flytekit/core/base_task.py", line 499, in dispatch_execute
        raise e
      File "/usr/local/lib/python3.10/site-packages/flytekit/core/base_task.py", line 496, in dispatch_execute
        native_outputs = self.execute(**native_inputs)
      File "/usr/local/lib/python3.10/site-packages/flytekit/extras/tasks/shell.py", line 215, in execute
        subprocess.check_call(gen_script, shell=True)
      File "/usr/local/lib/python3.10/subprocess.py", line 369, in check_call
        raise CalledProcessError(retcode, cmd)

Message:

    Command '
    mkdir -p output

    query=data/kitasatospora/k_sp_CB01950_penicillin.fasta
    db=data/kitasatospora/kitasatospora_proteins.faa
    blastout=output/AMK19_00175_blastx_kitasatospora.tab

    blastx -out $blastout -outfmt 6 -query $query -db $db >> stdout.txt 2>&1
    ' returned non-zero exit status 127.

SYSTEM ERROR! Contact platform administrators.
Any idea how to fix this?
k

Ketan (kumare3)

02/08/2023, 7:31 AM
Seems like a memory error? Cc @Samhita Alla she wrote the example
s

Samhita Alla

02/08/2023, 7:37 AM
It isn't a memory issue. It got to do with registration vs fast registration. The tasks require access to data. I'm working on making it work.
@Jay Phan created a PR to fix the example: https://github.com/flyteorg/flytesnacks/pull/957. Please take a look at the docs and let me know if you come across any issues. The specified docker image won't work cause it still needs to be updated. If you could build a docker image of your own and use the same, it should work.
j

Jay Phan

02/08/2023, 3:21 PM
@Samhita Alla sorry to bother you again, when I try to initiate the work flows on flyte back end using these 2 commands:
Copy code
pyflyte --pkgs blast package --image <http://ghcr.io/flyteorg/flytecookbook:blast-latest|ghcr.io/flyteorg/flytecookbook:blast-latest>
flytectl register files --project flytesnacks --domain development --archive flyte-package.tgz --version v1
I ran into this error:
Copy code
INFO[0000] [0] Couldn't find a config file []. Relying on env vars and pflags. 
panic: runtime error: invalid memory address or nil pointer dereference
[signal SIGSEGV: segmentation violation code=0x1 addr=0x0 pc=0x1f5dadb]

goroutine 1 [running]:
<http://github.com/flyteorg/flytectl/cmd/core.CommandContext.AdminClient(...)|github.com/flyteorg/flytectl/cmd/core.CommandContext.AdminClient(...)>
	/home/runner/work/flytectl/flytectl/cmd/core/cmd_ctx.go:57
<http://github.com/flyteorg/flytectl/cmd/register.register({0x30e6f78|github.com/flyteorg/flytectl/cmd/register.register({0x30e6f78>, 0xc000120000}, {0x30d98a0?, 0xc000953260?}, {0x0, {0x0, 0x0}, {0x0, 0x0}, {0x0, ...}, ...}, ...)
	/home/runner/work/flytectl/flytectl/cmd/register/register_util.go:188 +0x37b
<http://github.com/flyteorg/flytectl/cmd/register.registerFile({0x30e6f78|github.com/flyteorg/flytectl/cmd/register.registerFile({0x30e6f78>, 0xc000120000}, {0xc000cef2c0, _}, {_, _, _}, {0x0, {0x0, 0x0}, ...}, ...)
	/home/runner/work/flytectl/flytectl/cmd/register/register_util.go:606 +0x95b
<http://github.com/flyteorg/flytectl/cmd/register.Register({0x30e6f78|github.com/flyteorg/flytectl/cmd/register.Register({0x30e6f78>, 0xc000120000}, {0xc00015f600?, 0x0?, 0x0?}, 0x41b9520, {0x0, {0x0, 0x0}, {0x0, ...}, ...})
	/home/runner/work/flytectl/flytectl/cmd/register/files.go:160 +0x6ca
<http://github.com/flyteorg/flytectl/cmd/register.registerFromFilesFunc(|github.com/flyteorg/flytectl/cmd/register.registerFromFilesFunc(>{0x30e6f78, 0xc000120000}, {0xc00015f600, 0x1, 0x8}, {0x0, {0x0, 0x0}, {0x0, 0x0}, ...})
	/home/runner/work/flytectl/flytectl/cmd/register/files.go:118 +0xcd
<http://github.com/flyteorg/flytectl/cmd/core.generateCommandFunc.func1(0xc0009b8a00|github.com/flyteorg/flytectl/cmd/core.generateCommandFunc.func1(0xc0009b8a00>?, {0xc00015f600, 0x1, 0x8})
	/home/runner/work/flytectl/flytectl/cmd/core/cmd.go:70 +0x93d
<http://github.com/spf13/cobra.(*Command).execute(0xc0009b8a00|github.com/spf13/cobra.(*Command).execute(0xc0009b8a00>, {0xc00015f580, 0x8, 0x8})
	/home/runner/go/pkg/mod/github.com/spf13/cobra@v1.4.0/command.go:856 +0x67c
<http://github.com/spf13/cobra.(*Command).ExecuteC(0xc000cb7400)|github.com/spf13/cobra.(*Command).ExecuteC(0xc000cb7400)>
	/home/runner/go/pkg/mod/github.com/spf13/cobra@v1.4.0/command.go:974 +0x3b4
<http://github.com/spf13/cobra.(*Command).Execute(...)|github.com/spf13/cobra.(*Command).Execute(...)>
	/home/runner/go/pkg/mod/github.com/spf13/cobra@v1.4.0/command.go:902
<http://github.com/flyteorg/flytectl/cmd.ExecuteCmd()|github.com/flyteorg/flytectl/cmd.ExecuteCmd()>
	/home/runner/work/flytectl/flytectl/cmd/root.go:137 +0x1e
main.main()
	/home/runner/work/flytectl/flytectl/main.go:12 +0x1d
what is the config file referred to? Thanks
d

David Espejo (he/him)

02/08/2023, 7:46 PM
I think that [INFO] message on config can be safely ignored
s

Samhita Alla

02/12/2023, 10:43 AM
Um not sure what's happening. Can you tear down your demo cluster and spin it up again?
22 Views