Hi team, we want to upgrade our EKS to `1.22` that...
# ask-the-community
a
Hi team, we want to upgrade our EKS to
1.22
that removes support for quite a few beta APIs (link). Shall we expect any issues with Flyte (e.g does it depend on any of those beta APIs)? datacatalog_version = "v1.0.1" flyteadmin_version = "v1.1.21" flyteconsole_version = "v1.1.0" flytecopilot_version = "v0.0.26" flytepropeller_version = "v1.1.33"
d
Hey @Alex Pozimenko! We are not aware of any issues with 1.22. I know we have a few users who are running 1.22+ and have not reported anything. Locally, I have been developing all the way up to 1.25 with no issues (some deprecated APIs that will need to be updated, but no hard removals). Please let us know if you run into any issues and we will certainly help!
a
thanks @Dan Rammer (hamersaw). Just to confirm, we won't have to upgrade Flyte to run on EKS 1.22, correct?
d
I just ran through the merged PRs for flyteadmin and flytepropeller (the two repos communicating with k8s) and I don't see anything regarding k8s API upgrades. I never like to say that you will certainly have no problems 😅, but I am very confident that the upgrade will go smoothly.
118 Views