Running into a strange error when deploying flyte:...
# flyte-deployment
p
Running into a strange error when deploying flyte: • Using: opta from latest commit • Cloud provider: AWS • Region: eu-north-1 Had to bump to
flyteadmin:v0.6.110
and
flytescheduler:v0.6.110
to get around the db credentials problem Sören described above.
Copy code
{"json":{"src":"factory.go:97"},"level":"warning","msg":"Failed to initialize new gizmo aws subscriber with config [{Config:{AccessKey: MFASerialNumber: Region:eu-north-1 RoleARN: SecretKey: SessionToken: EndpointURL:\u003cnil\u003e} QueueName:flyte-dev-service-flyte-notifcationsQueue QueueOwnerAccountID:[REDACTED] QueueURL: MaxMessages:\u003cnil\u003e TimeoutSeconds:\u003cnil\u003e SleepInterval:\u003cnil\u003e DeleteBufferSize:\u003cnil\u003e ConsumeBase64:0x398494f}] and err: InvalidAddress: The address <https://sqs.eu-north-1.amazonaws.com/> is not valid for this endpoint.\n\tstatus code: 404, request id: 470cb213-271f-572e-b819-e88989f14c89","ts":"2022-03-03T11:55:26Z"}
{"json":{"src":"shared.go:23"},"level":"warning","msg":"Failed [InvalidAddress: The address <https://sqs.eu-north-1.amazonaws.com/> is not valid for this endpoint.\n\tstatus code: 404, request id: 470cb213-271f-572e-b819-e88989f14c89] on attempt 0 of 0","ts":"2022-03-03T11:55:26Z"}
The queue exists:
Copy code
aws sqs get-queue-url --queue-name flyte-dev-service-flyte-notifcationsQueue | jq '.QueueUrl' -r
<https://sqs.eu-north-1.amazonaws.com/[REDACTED]/flyte-dev-service-flyte-notifcationsQueue>
k
Cc @Haytham Abuelfutuh / @Yuvraj sqs is not a required thing, so maybe get started without it. @Paul Beskow this is not the root cause just an option.
y
@Ketan (kumare3) i have a pr for this, Just need to test the change then we can merge
k
Ok to root cause - why is it saying address and not the sqs arn?
p
Awesome, will disable notifications pending the fix 🙌
k
Cc @katrina have you seen this error?
k
woah no i haven't. googling only points to boto issues but that doesn't seem relevant here
p
For the
flyte_scheduler
component, we were able to get this working by changing to
type: native
in the
flyte.yaml
spec for the opta setup
k
It should always be native by default. Cc @Yuvraj
y
@Ketan (kumare3) In helm chart we already have native scheduler as default for eks https://github.com/flyteorg/flyte/blob/master/charts/flyte-core/values-eks.yaml#L334
p
That is how I figured it out, but the Opta flyte.yaml overrides it with aws I believe
k
Ohh no
139 Views