When running the `flytectl config init` command, ...
# flyte-deployment
a
When running the
flytectl config init
command, it seems to ignore all the options “inherited from parent commands”. For example, from the documentation ( https://docs.flyte.org/projects/flytectl/en/latest/gen/flytectl_config_init.html ) I would assume calling
flytectl config init --host=some.host --admin.clientSecretLocation=~/path/to/client/secret
would set the
admin.clientSecretLocation
in the config file, but it only sets the host. Or am I doing something wrong? How should I initialise or update the flytectl config file?
p
Right now config init command can set the host, console and insecure fields only due to the template it uses https://github.com/flyteorg/flytectl/blob/77deca5e3c446fbe54375c8d070a45862bc7ac07/pkg/configutil/configutil.go#L11_L22 Modifying this template to pass in that value can fix it , but would be good if there is better way to just use the command line args and expect those to be initialized in the file directly , the way you are trying to use it. For now you can manually edit the config.yaml file’s admin section and add the property
Copy code
insecure:<insecure-val>
clientSecretLocation:~/path/to/client/secret
a
@Prafulla Mahindrakar thanks for the answer! The documentation is super confusing, as it explicitly lists options for the
flytectl config init
command, but turns out they don’t have any effect. Just curious are those options used in some other context / or some other way?
p
it should mostly be applicable for all other commands except init . I think the issue being inheriting the same set of config flags in all the fltytectl subcommands but these inhertited flags are not applicable to some. Definitely not for init. Would be great if you can help with opening an issue for it .
a
thanks, will do!
121 Views