We are deploying Flyte this week :tada: Main piec...
# flyte-deployment
h
We are deploying Flyte this week ­čÄë Main pieces are running but configuration needs some adjustments. I have one question regarding TLS certificates. Is it required for grpc/flytectl to set up TLS on the Flyte endpoint? I get the following error with the current config. Is it only due to missing tls configuration or other reasons?
Copy code
flytectl get projects   
Error: Connection Info: [Endpoint: dns:///flyte.internal.n0q.eu, InsecureConnection?: true, AuthMode: ClientSecret]: rpc error: code = Unavailable desc = timed out waiting for server handshake
{"json":{},"level":"error","msg":"Connection Info: [Endpoint: dns:///flyte.internal.n0q.eu, InsecureConnection?: true, AuthMode: ClientSecret]: rpc error: code = Unavailable desc = timed out waiting for server handshake","ts":"2022-11-08T16:12:04+01:00"}

#~/.flyte/config.yaml
admin:
  # For GRPC endpoints you might want to use dns:///flyte.myexample.com
  endpoint: dns:///flyte.internal.eu
  insecure: true
  insecureSkipVerify: true
k
ItÔÇÖs not required but http2 does not like no TLS
h
Pasted the wrong error message, changed that now. So, is there a way to avoid the error or is it best to just configure tls?
k
This error is still weird
Authmode is clientsecret
Don you have auth enabled
h
Authentication was not enabled, we are working on that today.
Apparently, it was related to configuration of the load-balancer stripping certificates. Solved now Ôś║´ŞĆ
k
Cc @Katrina P / @Xuan Hu more deployment fun
116 Views