Thread
#flytekit
    Greg Gydush

    Greg Gydush

    4 months ago
    I seem to get this error often. Iā€™m trying
    hyper_parameters: Tuple[int, int, float, float, float]
    raise RestrictedTypeError(f"Transformer for type {self.python_type} is restricted currently")
    flytekit.core.type_engine.RestrictedTypeError: Transformer for type <class 'tuple'> is restricted currently
    Ketan (kumare3)

    Ketan (kumare3)

    4 months ago
    Tuple is a restricted type
    Can you use dataclass or something
    Greg Gydush

    Greg Gydush

    4 months ago
    Of course! Was curious about the "restricted currently" - will this always be the case for tuples?
    Ketan (kumare3)

    Ketan (kumare3)

    4 months ago
    I think we will support in the future
    But no plans, unless you can contribute šŸ˜Š