On the flyte UI, there's an option for `Only my ex...
# ask-the-community
l
On the flyte UI, there's an option for
Only my executions
filtering. Right now when I click on that, I get
Request failed with status code 400 invalid value for filters
What needs to be done for this to work? Do I have to set up OAuth login for the UI?
s
Hi Laura, thanks for your question. Before accessing the dashboard you must have used authentication right?
l
through eks vpc/vpn
s
Alright thanks for sharing. cc @Prafulla Mahindrakar / @katrina could comment here
s
Are you still seeing the error, @Laura Lin?
p
Hi @Laura Lin can you check whats the request being sent to the flyte backend.You can get this from dev console if your running in chrome browser and in the network tab check the request which is failing similar to the url given below. When i check this on an internal flyte system i dont see this issue. eg :
Copy code
<https://flyte-endpoint/api/v1/executions/flytesnacks/development?filters=eq(user,114527815305128974470)&limit=25&sort_by.direction=DESCENDING&sort_by.key=created_at>
Also assuming you have already setup oauth for this . If you haven’t and if you are seeing an error then it would be bug in the UI . In non-oauth enabled UI you shouldn’t be able to get
Only my executions
. This functionality should be disabled. If you see this behavior please do open a bug for it.
l
I haven't set up oath yet.
p
Created an issue here as its a UI bug https://github.com/flyteorg/flyte/issues/3028
102 Views