https://flyte.org logo
#flytekit
Title
# flytekit
r

Rahul Mehta

10/11/2022, 4:52 PM
Hey, we're writing a flytekit plugin and am setting up our repo. I have a
<http://requirements.in|requirements.in>
file that includes
flytekit~=1.2.0
(to allow the patch version to float), and
pip-compile
is failing with the following deps error:
Copy code
There are incompatible versions in the resolved dependencies:
  protobuf<4.0.0,>=3.5.0 (from flyteidl==1.1.21->flytekit==1.2.1->-r <http://requirements.in|requirements.in> (line 1))
  protobuf<4,>=3.6.1 (from flytekit==1.2.1->-r <http://requirements.in|requirements.in> (line 1))
  protobuf>=4.21.3 (from grpcio-status==1.49.1->flytekit==1.2.1->-r <http://requirements.in|requirements.in> (line 1))
Curious how the build is passing in the flytekit repo given this? Do we need to more tightly pin
grpcio-status
?
a

Andrew Achkar

10/11/2022, 4:57 PM
Seen this too, had to provide a pin to grpcio-status. There’s an open issue: https://github.com/flyteorg/flyte/issues/2887, but would be nice to give it some more attention.
Arguably pip-compile’s solver is not being exhaustive enough…
k

Kevin Su

10/11/2022, 6:08 PM
Add
grpcio-status
to requirements.in can fix it.
Copy code
flytekit~=1.2.0                                                                                              
grpcio-status<=1.47.0
...
cc @Rahul Mehta Could you try this ^^^
y

Yee

10/11/2022, 6:15 PM
and yeah this is a known issue. We are going to address this soon.
thanks kevin
r

Rahul Mehta

10/11/2022, 7:16 PM
Thanks @Andrew Achkar this worked for us!
We'll remove it once it's fixed but this unblocks us for now
78 Views