Are there any major “gotchas” to upgrading from a ...
# ask-the-community
r
Are there any major “gotchas” to upgrading from a much older flytepropeller/flyteplugins to a more recent version? Are there any changes required for users who register their workflows (i.e. upgrading flytekit or anything like that)?
cc: @Eli Schachar
e
how much older are we talking about? pre-1.0 ?
r
Yes, 0.13.15 I believe.
k
i do not know if you can upgrade to 1.0.0
r
Ruh Roh. We’d have to start from scratch you think?
k
Hmm so some entities have changed a bit
It’s not a lot, but we made some changes for scale
Let’s have a chat?
r
Sure, does tomorrow work for a chat though?
k
Why do you folks want to upgrade? Just to understand context
r
I’m not sure we need to at the moment. Right now we’re in Kubernetes 1.16, and I believe we need to move to Kubernetes 1.22. I’m not sure if upgrading propeller to support this would be required or not.
k
I don’t think so
Just crd update
r
Ah, perfect.
106 Views