Thread
#flytekit
    Tim Bauer

    Tim Bauer

    5 months ago
    Anyone else having dependency conflicts when pip installing from flytekit master? I get:
    ERROR: Could not find a version that satisfies the requirement grpcio<2.0,>=1.45.0 (from flytekit) (from versions: 0.4.0a0, 0.4.0a1, 0.4.0a2, 0.4.0a3, 0.4.0a4, 0.4.0a5, 0.4.0a6, 0.4.0a7, 0.4.0a8, 0.4.0a13, 0.4.0a14, 0.5.0a0, 0.5.0a1, 0.5.0a2, 0.9.0a0, 0.9.0a1, 0.10.0a0, 0.11.0b0, 0.11.0b1, 0.12.0b0, 0.13.0, 0.13.1rc1, 0.13.1, 0.14.0rc1, 0.14.0, 0.15.0, 1.0.0rc1, 1.0.0rc2, 1.0.0, 1.0.1rc1, 1.0.1, 1.0.2, 1.0.3, 1.0.4, 1.1.0, 1.1.3, 1.2.0, 1.2.1, 1.3.0, 1.3.5, 1.4.0, 1.6.0, 1.6.3, 1.7.0, 1.7.3, 1.8.1, 1.8.2, 1.8.3, 1.8.4, 1.8.6, 1.9.0rc1, 1.9.0rc2, 1.9.0rc3, 1.9.0, 1.9.1, 1.10.0rc1, 1.10.0rc2, 1.10.0, 1.10.1rc1, 1.10.1rc2, 1.10.1, 1.11.0rc1, 1.11.0rc2, 1.11.0, 1.11.1rc1, 1.11.1, 1.12.0rc1, 1.12.0, 1.12.1, 1.13.0rc1, 1.13.0rc2, 1.13.0rc3, 1.13.0, 1.14.0rc1, 1.14.0rc2, 1.14.0, 1.14.1, 1.14.2rc1, 1.14.2, 1.15.0rc1, 1.15.0, 1.16.0rc1, 1.16.0, 1.16.1, 1.17.0, 1.17.1, 1.18.0, 1.19.0, 1.20.0rc1, 1.20.0rc2, 1.20.0rc3, 1.20.0, 1.20.1, 1.21.0rc1, 1.21.1rc1, 1.21.1, 1.22.0rc1, 1.22.0, 1.22.1, 1.23.0rc1, 1.23.0, 1.23.1, 1.24.0rc1, 1.24.0, 1.24.1, 1.24.3, 1.25.0rc1, 1.25.0, 1.26.0rc1, 1.26.0, 1.27.0rc1, 1.27.0rc2, 1.27.1, 1.27.2, 1.28.0.dev0, 1.28.0rc1, 1.28.0rc2, 1.28.0rc3, 1.28.1, 1.29.0, 1.30.0rc1, 1.30.0, 1.31.0rc1, 1.31.0rc2, 1.31.0, 1.32.0rc1, 1.32.0, 1.33.0rc1, 1.33.0rc2, 1.33.1, 1.33.2, 1.34.0rc1, 1.34.0, 1.34.1, 1.35.0rc1, 1.35.0, 1.36.0rc1, 1.36.0, 1.36.1, 1.37.0rc1, 1.37.0, 1.37.1, 1.38.0rc1, 1.38.0, 1.38.1, 1.39.0rc1, 1.39.0, 1.40.0rc1, 1.40.0, 1.41.0rc2, 1.41.0, 1.41.1, 1.42.0rc1, 1.42.0, 1.43.0rc1, 1.43.0, 1.44.0rc1, 1.44.0rc2, 1.44.0, 1.45.0rc1, 1.45.0)
    ERROR: No matching distribution found for grpcio<2.0,>=1.45.0
    Bump to >=1.45.0 happened four days ago Irony is 1.45.0 is listed as available 😄
    Looks like grpcio 1.45.0 was yanked:
    WARNING: The candidate selected for download or install is a yanked version: 'grpcio' candidate (version 1.45.0 at <https://files.pythonhosted.org/packages/7e/16/8ba5fd3289e0a75244689a25ae96f9055af2f6489abcaf430bb0256a8789/grpcio-1.45.0-cp39-cp39-manylinux_2_17_x86_64.manylinux2014_x86_64.whl#sha256=0fe6acb1439127e0bee773f8a9a3ece290cb4cac4fe8d46b10bc8dda250a990c> (from <https://pypi.org/simple/grpcio/>) (requires-python:>=3.6))
    Reason for being yanked: Segfaults
    Ketan (kumare3)

    Ketan (kumare3)

    5 months ago
    Cc @Eduardo Apolinario (eapolinario) / @Yee
    Tim Bauer

    Tim Bauer

    5 months ago
    Looks like those two here haven't caught up on the yank and require grpcio>=1.45.0 via
    grpcio>=1.45.0 (from grpcio-status==1.45.0->google-api-core[grpc]==2.7.1->google-cloud-bigquery==3.0.1->-r <http://dev-requirements.in|dev-requirements.in> (line 11))
    Yee

    Yee

    5 months ago
    still working on reviewing that PR tim.
    sorry unrelated.
    why is pip install using the dev requirements though - can you just skip those?
    Eduardo Apolinario (eapolinario)

    Eduardo Apolinario (eapolinario)

    5 months ago
    I'm not sure why
    grpcio-status==1.45.0
    was not yanked, but excluding that also should do the trick: https://github.com/flyteorg/flytekit/pull/913. I mention a ticket on the grpc github where a grpc-related package is seeing a similar issue. The grpc team probably forgot to yank all those versions too.
    As I mentioned above,
    grpcio-status
    is now yanked, but out of an abundance of caution we'll be skipping that version.