<@U06RKAMK0UC> I am just getting started with flyt...
# ask-ai
b
@RunLLM I am just getting started with flyte and I am working on setting up a dev environment that uses vs code dev containers. When I run flytectl demo start I can see it download the image but it errors out like this
Copy code
flytectl demo start
INFO[0000] [0] Couldn't find a config file []. Relying on env vars and pflags. 
šŸ§‘ā€šŸ­ Bootstrapping a brand new Flyte cluster... šŸ”Ø šŸ”§
šŸ‹ Going to use Flyte v1.12.0 release with image <http://cr.flyte.org/flyteorg/flyte-sandbox-bundled:sha-bd3ed0d2684bddbc8fad1c26d4bc39a86e91077f|cr.flyte.org/flyteorg/flyte-sandbox-bundled:sha-bd3ed0d2684bddbc8fad1c26d4bc39a86e91077f> 
šŸ§‘ā€šŸ­ Starting container... šŸ”Ø šŸ”§
šŸ˜¬ Something went wrong: Failed to start Sandbox container šŸ‹, Please check your docker client and try again. 
Error: Error response from daemon: invalid mount config for type "bind": bind source path does not exist: /home/vscode/.flyte
{"json":{},"level":"error","msg":"Error response from daemon: invalid mount config for type \"bind\": bind source path does not exist: /home/vscode/.flyte","ts":"2024-05-19T19:21:46Z"}
I can see that the
/home/vscode/.flyte
path exists and there is the proper directory structure with files there
r
The error indicates that Docker is unable to find the bind source path
/home/vscode/.flyte
. This could be due to permission issues or incorrect path resolution within the Docker container. 1. Verify Path and Permissions: Ensure that the path
/home/vscode/.flyte
exists and has the correct permissions. 2. Check Docker Configuration: Ensure Docker has the necessary permissions to access the path. You might need to adjust Docker's settings to allow access to the directory. Would you like more detailed steps on how to verify and adjust these settings? Sources: - https://discuss.flyte.org/t/12922931/hi-im-running-into-an-issue-when-trying-to-set-up-a-dev-envi/ - https://github.com/flyteorg/flyte/issues/3645 šŸ‘ 0 button šŸ‘Ž 1 button šŸ’” Hint: Mention @RunLLM in the thread for followups.