Hi Flyte Community, I am trying to create a Contai...
# ask-the-community
Hi Flyte Community, I am trying to create a ContainerTask that uses a private container registry in Azure. The workflow is running remotely in a Kubernetes cluster. This container task has a FlyteFile as an input that is stored in blob storage in Azure. The problem is with the outputs. I am getting the following error:
"Last Error: UNKNOWN::Outputs not generated by task execution"
and nothing is being stored in the blob storage. Checking the logs of the pod there is no error whatsoever. Any idea what might be causing this issue?
hello - are you running flyte-binary or core? have you confirmed the downloader container is authenticating correctly? (see this thread)
Hi 🙂 We are running flyte-binary and yes, we can authenticate and get the image correctly. The access to the inputs in the storage account also works. After a lot of debugging, I found out in the flyte-sidecar logs this error:
{"json":{},"level":"error","msg":"Failed to upload [result], reason [maximum allowed filesize is [1024], but found [731535]]","ts":"2024-04-23T08:41:12Z"}
. I tried updating the values.yaml for flyte by adding
to a random value just to see if it would make any difference but the allowed filesize of 1024 didn't change. Any ideas on how I can solve this? Thank you :) Note: I can't access the thread since it is older than 90 days and I don't have Slack Pro.
can you paste the definition of the
I solved it by fixing some bugs, but one of them I basically had to put the enable-multicontainer to true under storage in the values.yaml. Thanks anyway :)