https://flyte.org logo
#ask-the-community
Title
# ask-the-community
n

Noah Jackson

02/28/2024, 12:31 AM
Hi all, What is the intended way to execute a remote launch plan using an input that exists locally? I am running into issues doing something like
Copy code
pyflyte run remote-workflow workflow.simple_input_flow --input=input.txt
The issue is that flytekit doesn't upload
input.txt
to s3 the way it would if I were creating the workflow via
Copy code
pyflyte run --remote workflow.py simple_input_flow --input=input.txt
In the former example flytekit will use a path like
/tmp/flyte-3x5f57__/raw/6b1dee242a380ced7fe1e44af4f3a36b/input.txt
to refer to the file, which will cause the task to fail. In contrast, the latter case correctly uploads the file to s3 and the file will be referenced by a path like
<s3://noahfly37041-flyte-data/flytesnacks/development/WTIDKJAQCPBKDYDRFRUHFJPKBM======/input.txt>
I'm not sure if I'm going about this in the wrong way or if this is a bug that impacts my specific use case
k

Ketan (kumare3)

02/28/2024, 4:58 AM
interesting. This is a bug. Can you please file it. The problem is type guessing may be little awkward. Also if you can offer a fix that would be awesome. Can you also for me check what the type of the param is.
pyflyte run remote-workflow workflow.simple_input_flow --input=input.txt --help
I think its something really simple, like marking the remote flag as true
cc @L godlike / @Samhita Alla can you add this fix?
@Noah Jackson you could propose a fix too, but whoever does, please claim it here. This should be simple
l

L godlike

02/28/2024, 5:33 AM
Can take a look later, working on other issues
thx
interesting issue
s

Samhita Alla

02/28/2024, 10:02 AM
@Ketan (kumare3) https://github.com/flyteorg/flytekit/pull/2222 should fix the issue. could you review the changes and confirm if they look correct to you?
k

Ketan (kumare3)

02/28/2024, 3:08 PM
Looks good will take a deeper look, did you try regular run and also remote-task etc just to ensure
n

Noah Jackson

02/28/2024, 4:58 PM
Thanks for the quick turnaround, I just tried this using the fix branch and my use case works now
s

Samhita Alla

02/28/2024, 5:47 PM
@Ketan (kumare3) yes, remote-task, remote-workflow and regular run work.
k

Ketan (kumare3)

02/28/2024, 11:04 PM
awesome merge it