https://flyte.org logo
#ask-the-community
Title
# ask-the-community
a

avesuni

01/15/2024, 1:13 PM
Help with resource limits appreciated.
flytectl get task-resource-attribute -p foo -d development
gives
{"project":"foo","domain":"development","defaults":{"cpu":"1","memory":"1Gi"},"limits":{"cpu":"20","memory":"200Gi"}}
Running a workflow gives
requested resources exceed limits: [BackOffError] The operation was attempted but failed, caused by: pods "f4490a01253a7422a94a-n1-0" is forbidden: exceeded quota: project-quota, requested: limits.cpu=10,limits.memory=30Gi, used: limits.cpu=0,limits.memory=0, limited: limits.cpu=2,limits.memory=3000Mi
Cluster-wide settings
task_resource_defaults:
task_resources:
defaults:
cpu: 1000m
memory: 1000Mi
storage: 1000Mi
limits:
cpu: 20
memory: 200Gi
storage: 300Gi
j

Jake Dodd

01/15/2024, 1:47 PM
Hi @avesuni, we had a similar issue for a while, our issue was in the
cluster_resource_manager.config.cluster_resources.customData.development.projectQuotaMemory.value
value, once we increased this it started working
a

avesuni

01/15/2024, 2:04 PM
Thanks @Jake Dodd. I realised I had enabled
cluster_resource_manager
without overriding default values.
6 Views