https://flyte.org logo
#ask-the-community
Title
# ask-the-community
j

Jayanth S N

01/11/2024, 12:48 AM
Hi Team, we are using flyte 1.10.2 in our organization and we are running workflows pretty much smoothly. However we wanted to explore map_task along with python notebook to spin up notebook parallel associate with parallel task, while testing basic map_task functionality all we are getting is this below error. Other workflows are working fine this is appearing only for map_task related workflows.
Last error: UNKNOWN::Outputs not generated by task execution (edited)
We also tried the experimental.map_task also, but the issue remained same.
Copy code
from typing import List

from flytekit import map_task, task, workflow

@task
def a_mappable_task(a: int) -> str:
  inc = a + 2
  print(inc)
  return str(inc)


@workflow
def my_map_workflow(a: List[int]) -> List[str]:
  mapped_out = map_task(a_mappable_task)(a=a)
  return mapped_out

if __name__ == "__main__":
  result = my_map_workflow(a=[2,3,4,5])
  print(f"{result}")
this is the simple code snippet, we are using to test. When we look into logs we are only able to see the first iterated item. In this case, its 2 and in log the print shows 4 as its incremented and next whole workflow fails with the above error. Could someone please assist us in determining what we may have overlooked in configuration that is creating this issue?
k

Ketan (kumare3)

01/11/2024, 5:59 AM
output not generated implies in some case the map task did not complete or returned a none
i am trying your example
worked for me
j

Jayanth S N

01/11/2024, 6:09 AM
Hey, Thanks for checking and the update. Yes you are correct, its working in my local as well. However its not working in our cluster. That means the code is fine. Do you know what else might be the issue? Also I have attached screenshot here, I tried to see if the output file / subtask file exists. By looking at AWS S3 lokks like out put file is generating.
s

Samhita Alla

01/11/2024, 6:20 AM
have you looked at the map task logs? what do you see when you run
kubectl get pods -n flyte
?
k

Ketan (kumare3)

01/11/2024, 6:26 AM
Sorry I meant it works on my cluster. It seems like some file is missing or something went wrong / maybe perms