https://flyte.org logo
#ask-the-community
Title
# ask-the-community
m

Mario Mukke

12/06/2023, 9:00 AM
Hello, i tested the Flyte Sandbox on my M1 Mac yesterday. The container is started and the web console is also accessible. However, when I try to start the example with pyflyte --remote flag, i get the following output and then nothing happens. Can someone help?
Copy code
pyflyte --verbose run --remote example.py training_workflow --hyperparameters '{"C": 0.1}'
Running example.training_workflow with {'hyperparameters': <FlyteLiteral scalar { generic { fields { key: "C" value { number_value: 0.1 } } } }>} and run_level_params RunLevelParams(config_file=None, verbose=True, pkgs=[], project='flytesnacks', domain='development', destination_dir='/root', copy_all=False, image_config=ImageConfig(default_image=Image(name='default', fqn='<http://cr.flyte.org/flyteorg/flytekit|cr.flyte.org/flyteorg/flytekit>', tag='py3.11-1.10.1'), images=[Image(name='default', fqn='<http://cr.flyte.org/flyteorg/flytekit|cr.flyte.org/flyteorg/flytekit>', tag='py3.11-1.10.1')]), service_account='', wait_execution=False, dump_snippet=False, overwrite_cache=False, envvars=None, tags=(), name=None, labels=None, annotations=None, raw_output_data_prefix=None, max_parallelism=None, disable_notifications=False, remote=True, limit=10, cluster_pool='', computed_params=RunLevelComputedParams(project_root='/Users/mario/project/test', module='example', temp_file_name=None), _remote=<flytekit.remote.remote.FlyteRemote object at 0x11ca1cd10>)
Running Execution on Remote.
d

David Espejo (he/him)

12/06/2023, 12:05 PM
is there any execution visible on
<http://localhost:30080>
?
m

Mario Mukke

12/06/2023, 12:16 PM
No, even after several minutes no execution is visible.
d

David Espejo (he/him)

12/06/2023, 12:39 PM
is the
FLYTECTL_CONFIG
configured? like
export FLYTECTL_CONFIG=$HOME/.flyte/config-sandbox.yaml
m

Mario Mukke

12/06/2023, 12:43 PM
Yes.
Copy code
❯ echo $FLYTECTL_CONFIG
/Users/mario/.flyte/config-sandbox.yaml
d

David Espejo (he/him)

12/06/2023, 12:51 PM
what's the status of the container?
flytectl demo status
m

Mario Mukke

12/06/2023, 12:55 PM
Copy code
❯ flytectl demo status
Flyte local sandbox container image [<http://cr.flyte.org/flyteorg/flyte-sandbox-bundled:sha-fa49d3bfcdc081328e2f1514fd513ec46fdbf734|cr.flyte.org/flyteorg/flyte-sandbox-bundled:sha-fa49d3bfcdc081328e2f1514fd513ec46fdbf734>] with status [Up 18 hours] is in state [running]
s

Samhita Alla

12/06/2023, 4:49 PM
have you tried registering first and triggering the execution later on the UI? you can run
pyflyte register example.py
command first, followed by launching the workflow on the UI.
regarding the
pyflyte run
command not working as expected, have you checked the statuses of the pods:
kubectl get pods --all-namespaces
?
m

Mario Mukke

12/06/2023, 8:23 PM
hi, thanks. i have tried to register the
example.py.
i get the following output
Copy code
pyflyte register example.py
Running pyflyte register from /Users/mario/projects/flyte with images ImageConfig(default_image=Image(name='default', fqn='cr.flyte.org/flyteorg/flytekit', tag='py3.11-1.10.1'), images=[Image(name='default', fqn='cr.flyte.org/flyteorg/flytekit', tag='py3.11-1.10.1')]) and image destination folder /root on 1 package(s) ('/Users/mario/projects/flyte/example.py',)
Registering against localhost:30080
Detected Root /Users/mario/projects/flyte, using this to create deployable package...
No output path provided, using a temporary directory at /var/folders/cf/cbzf91kj7rgd1f2t1cw5t9lh0000gn/T/tmpq9thcd0h instead
Computed version is 1dGdaUfD99GiOngFlcwbTQ==
that's it. after that nothing happens. the pods are running
Copy code
NAMESPACE     NAME                                                  READY   STATUS    RESTARTS   AGE
flyte         flyte-sandbox-proxy-d95874857-qk287                   1/1     Running   0          25h
flyte         flyte-sandbox-docker-registry-6ddd797ddb-szc7r        1/1     Running   0          25h
kube-system   coredns-b96499967-q5898                               1/1     Running   0          25h
kube-system   local-path-provisioner-7b7dc8d6f5-cf6vh               1/1     Running   0          25h
flyte         flyte-sandbox-kubernetes-dashboard-6757db879c-nbx5x   1/1     Running   0          25h
flyte         flyte-sandbox-buildkit-7d7d55dbb-fzxk9                1/1     Running   0          25h
flyte         flyte-sandbox-minio-645c8ddf7c-m57nj                  1/1     Running   0          25h
kube-system   metrics-server-668d979685-lhmgh                       1/1     Running   0          25h
flyte         flyte-sandbox-postgresql-0                            1/1     Running   0          25h
flyte         flyte-sandbox-76f7d4c6c9-g22mz                        1/1     Running   0          25h
flyte         flyteagent-7b7f469dbf-2qkx4                           1/1     Running   0          25h
Ok, i found the error. When i create the python env with
poetry
, the pyflyte remote call does not work. When i create the python env with
python -m venv .venv
the pyflyte remote call works. tested with python 3.11.6 and 3.10.4
s

Samhita Alla

12/07/2023, 9:38 AM
ah, okay. good to know that you got it to work!
3 Views