Any idea why I'd be getting a 404 when clicking on...
# ask-the-community
Any idea why I'd be getting a 404 when clicking on an execution in the console?
Have confirmed I can run
Copy code
flytectl get execution -p flyte -d development f8045590d18804db785c --details
and it returns a tree in the terminal which I think means the data does exist
@Gopal Vashishtha do you see any errors in the console? Do you mind sharing a screenshot including the breadcrumbs or share the url path? cc @Frank Flitton
Also, if you click on the info button in the header, what UI version / Package version are you on?
@Gopal Vashishtha Which page/link did you click on before you saw the 404 screen?
I was going directly to
. The script that kicks off my run autogenerates this path for me using the return values of remote.execute
the 501s are "axios api calls"
what happens if you try to directly access one of those GET requests? Like
? Does loading
work or has it worked in the past? It seems like console requests are coming back as 501’s, which sounds like an issue with the backend
is your admin api configured correctly? cc @Yee
shouldn’t that be domain instead of domains?
oh i guess not
yeah can you try looking at the api call for that execution directly?
flytectl uses grpc and web uses normal http so maybe there’s an issue with the ingress/service on the k8s side.
@Yee based on the console screenshot, it looks like even /me is returning 501, looks like probably none of the api calls are succeeding
can you port forward the admin service locally 8088 i believe, and confirm the api/v1/executions link as well
this is with port-forwarding
but when I go to the URL the frontend was requesting, I get:
I'm deploying with flyte-binary, possible I need to do some additional configuration to tell the frontend to use a different URL template for calling the backend?
also /console in general does work, I can see tasks just not details of executions
could the problem potentially be that I need to disable auth?
disabled auth, "login" button disappears but 404 stays there. Another thing to note: I'm on azure so maybe there's some part of this page that expects S3 instead of azure blob?
the helm chart should work. there are no hardcoded s3 paths that i’m aware of, everything should be configurable via helm values.
when i look at the execution link of a working deployment, my link is;fromExecutionNav=true. in your link the
bit seems to be missing
also not sure what the missing identityservice is about. that’s happening when you have auth enabled?
The /console link is here, see my earlier message. The missing identity service happens in both cases
i was referring to this one
i don’t think that link will ever work.
can you share a screenshot of the failed network call for the 404 case when nothing is port-forwarded as well please? not the chrome console link but the network tab expansion.
I saw something related with 404 errors too when upgrading from flyte 1.5 to 1.8, posted about it here ended up rolling back.
is the culprit:
so it can't find my workflow, where does /api/v1/workflows look for workflows? How can I debug?
could the problem be that my workflow version has a forward slash in the name?
ah but
flytectl get workflows -p flyte -d development
also can't find my workflow. even though
kubectl get flyteworkflows
does. Do workflows not get created automatically when a task is created?
the 501 on me is okay, that’s supposed to happen if you don’t have auth set.
not sure what read-azure is but I think that’s separate.
that's the version of my workflow, I think the problem is I created a task but not a workflow