https://flyte.org logo
#ask-the-community
Title
# ask-the-community
f

Frank Shen

06/02/2023, 4:16 PM
Hello, How can I tell what minimum version of flytekit is that supports ImageSpec?
f

Fabio Grätz

06/02/2023, 4:20 PM
I think it’s 1.6.x
f

Frank Shen

06/02/2023, 4:22 PM
Thanks @Fabio Grätz
e

Evan Sadler

06/02/2023, 9:09 PM
@Frank Shen I would recommend using the latest release 1.6.2 if you are running spark jobs! Let me know if you are and I can share some code. We have not checked it with the backend plugin and are happy to partner on getting it setup. Just let me know!
f

Frank Shen

06/02/2023, 9:13 PM
@Evan Sadler, due to feathr ’s dependency conflict, we cannot upgrade to 1.6.x
e

Evan Sadler

06/02/2023, 9:14 PM
can you share the conflicts with us?
I will look into resolving those for you
@Frank Shen
I just ran
pip install flytekit feathr
and was able to install and import both libraries. What did you try that wasn't working? Any details are very helpful @Frank Shen
f

Frank Shen

06/03/2023, 4:43 AM
@Evan Sadler, we have a tailored feathr at 0.9 CR . We need to upgrade that first. And we have a tech debt with Asad’s absence.
68 Views