I'm trying to setup my dev environment. I install...
# ask-the-community
r
I'm trying to setup my dev environment. I installed flytekit and the requirements for flytesnacks in an venv as recommended here: https://docs.flyte.org/projects/cookbook/en/latest/userguide_setup.html However, my pyflyte looks broken. I can't run any commands as they all fail with: ModuleNotFoundError: No module named 'flyteidl.service.external_plugin_service_pb2_grpc' That module definitely isn't installed in my venv, and I don't see the proto for it in the flyteidl repo either. Have I installed a wrong version of flytekit somehow?
y
cc @Kevin Su
is this a renaming thing?
try to just upgrade flyteidl to latest for now
Copy code
pip install --upgrade flyteidl
k
Use flyteidl==1.5.8 instead
y
we’ve yanked the latest 1.5.9 flyteidl release. sorry for the trouble.
r
I re-installed flyteidl via: pip install --upgrade flyteidl==1.5.8 But I still see the same error when trying to do
pyflyte --help
I have flytekit==1.6.2 installed
I found the issue. I'm on a mac and have a pyflyte installed in /opt/homebrew/bin, however i have no idea where that came from. I tried uninstalling flytectl, but the file remained. Trying to list files with brew didn't give any indications what package owns it, but iirc only flytectl is installed via brew in the env setup. If I make sure to use the pyflyte in my venv then everything works.
Sorry for the confusion, although it's still confusing. 😄
y
no worries, sorry again for the trouble. we’ve added a pin to avoid issues like this in the future.
r
I'm not sure if this was related to anything on your end. 😄 That erroneous pyflyte binary on my system caused a lot of it I think. Just not sure where that came from
116 Views