Could we please make a 1.6.2 patch release contain...
# contribute
f
Could we please make a 1.6.2 patch release containing this fix? I’d like to upgrade to 1.6 but can’t pip-compile flytekit and plugins in parallel from a pinned commit:
Copy code
ERROR: Cannot install flytekit 0.0.0+develop (from git+ssh://****@github.com/flyteorg/flytekit.git@f671fb68092979b0328b97453d0ba0d396a6398e) and <internal-package> (<internal-package>/pyproject.toml) because these package versions have conflicting dependencies.
  
  The conflict is caused by:
      The user requested flytekit 0.0.0+develop (from git+ssh://****@github.com/flyteorg/flytekit.git@f671fb68092979b0328b97453d0ba0d396a6398e)
      flytekitplugins-deck-standard 0.0.0+develop depends on flytekit<2.0.0 and >=1.3.0b2
I saw that theoretically I have the permissions to make releases in flytekit 🤔 I’m not sure if this is intended. If you agree with making a 1.6.2 patch release for this fix and if it’s on purpose that I have the permission to publish releases, is it ok if I go ahead and create the release? Also happy to wait for somebody else to do this though if its not on purpose for me to have the permissions.
k
yes, we can cut a release. cc @Eduardo Apolinario (eapolinario) @Yee
y
yeah let’s do it please.
f
Do you want me to make the release or do you prefer doing it yourself @Yee @Eduardo Apolinario (eapolinario)? Both is 100% ok for me :)
y
you do it
please
just generate the auto changelog too
f
👍 generated the auto changelog
y
thanks!
f
Thanks for confirming that I should go ahead and release. Will obviously not do so without explicitly checking in also in the future …
y
re-running, should be fine.
f
Triggered
Did fix it
150 Views