I was able to install a helm release via terraform...
# flyte-deployment
n
I was able to install a helm release via terraform to deploy flyte on our eks cluster. I am seeing a couple of issues, if someone has seen these please share possible issue / fix - 1. I cannot see any pods running when I run
kubectl get pods -n <my-namespace>
2. When I run
kubectl get svc -n <my-namespace>
I see three services instead of one flyte-binary service -
Copy code
NAME                                 TYPE        CLUSTER-IP       EXTERNAL-IP   PORT(S)    AGE
flyte-backend-flyte-binary-grpc      ClusterIP   10.100.105.242   <none>        8089/TCP   33m
flyte-backend-flyte-binary-http      ClusterIP   10.100.202.80    <none>        8088/TCP   33m
flyte-backend-flyte-binary-webhook   ClusterIP   10.100.196.242   <none>        443/TCP    33m
I am following this simple cloud deployment. When I try to port-forward any of the three services, the kubectl command times out.
kubectl get events
does not show anything related to flyte.
y
if you’re getting a timeout, i would try port forwarding from the node backing the service first.
i don’t think i’ve seen a timeout before
d
@Nandakumar Raghu you mean no pods in your namespace? or is there any in a state different than
Running
? It's weird that it created the services and not the Pod. Regarding #2 yes, recent chart versions create separate services, this was needed to meet the requirements of some ingress controllers that have specific annotation for each type of traffic (gRPC, http,etc)
n
To close this out, 1. was not an issue, there was an un scheduled maintenance on the cluster due to which pods were not allowed to run. 2. I have some additional questions regarding the split services, ingress and SSL. I'll post a new question for that. Thanks!
120 Views