been reading up on some of the new features and fo...
# ask-the-community
l
been reading up on some of the new features and found out about this approve https://github.com/flyteorg/flytesnacks/blob/master/cookbook/core/control_flow/waiting_for_external_inputs.py#L150-L158. When I tried doing fast registration after copying pasting, it errors out with the following.
Copy code
RPC Failed, with Status: StatusCode.INTERNAL
	details: failed to compile workflow for [resource_type:WORKFLOW project:"flytetester" domain:"development" name:"flyte.example.reporting_with_approval_wf" version:"unique-version" ] with err failed to compile workflow with err Collected Errors: 2
	Error 0: Code: ParameterNotBound, Node Id: end-node, Description: Parameter not bound [o0].
	Error 1: Code: VariableNameNotFound, Node Id: n3, Description: Variable [o0] not found on node [n3].
locally, I have flytekit==1.5.0 and flytectl version returns
Copy code
{
 "App": "flytectl",
 "Build": "bd6b856",
 "Version": "0.6.36",
 "BuildTime": "2023-04-27 15:25:39.086187 -0700 PDT m=+0.020923408"
}{
 "App": "controlPlane",
 "Build": "326ca45",
 "Version": "v1.1.77",
 "BuildTime": "2023-03-29 02:39:36.093681223 +0000 UTC m=+0.135808640"
}%
do I need to upgrade the controlplane?
k
What about backend
It needs a newer backed version
l
ah, yea I think that fixed it. I pulled in helm chart updates and then upgraded the deployment. seems to have fixed it
this is a really cool feature!
162 Views