https://flyte.org logo
#flytekit
Title
# flytekit
s

seunggs

04/08/2023, 9:12 PM
FYI - flytekit 1.5.0 seems to have dependency conflicts -
Could not find a version that matches fsspec==2023.3.0,==2023.4.0,>=2021.10.1,>=2023.3.0
k

Ketan (kumare3)

04/08/2023, 9:35 PM
Cc @Yee
@Eduardo Apolinario (eapolinario)
@seunggs where do you see this conflict
s

seunggs

04/08/2023, 9:52 PM
Running
pip-compile
- the error goes away if I revert back to <=1.4.2:
Copy code
There are incompatible versions in the resolved dependencies:
  fsspec>=2021.10.1 (from adlfs==2023.1.0->flytekit==1.5.0)
  fsspec==2023.3.0 (from gcsfs==2023.3.0->flytekit==1.5.0)
  fsspec==2023.4.0 (from s3fs==2023.4.0->flytekit==1.5.0)
  fsspec>=2023.3.0 (from flytekit==1.5.0)
y

Yee

04/10/2023, 6:38 PM
can you trace where it’s coming from?
flytekit itself does not pin
s

seunggs

04/10/2023, 6:40 PM
Hmm ok I’ll look into it more thanks @Yee
e

Eduardo Apolinario (eapolinario)

04/13/2023, 5:35 PM
@seunggs, were you able to figure this out?
s

seunggs

04/14/2023, 2:03 PM
Sorry haven’t had time to look at it yet - I reverted it to 1.4.2 for now
Will let you know when I do
95 Views