Thread
#announcements
    e

    Eugene Cha

    8 months ago
    what kubernetes versions (min, max) does flyte support?
    Samhita Alla

    Samhita Alla

    8 months ago
    I think min is 1.19. Not sure though. cc: @Prafulla Mahindrakar / @Yuvraj
    p

    Prafulla Mahindrakar

    8 months ago
    internally we have clusters ranging from 1.18 to 1.21 . I would defer to @Haytham Abuelfutuh / @Yuvraj to provide if we recommend any minimum version for deployment . I know that 1.16 didn't work for me on EKS since certain ingress annotations didn't work on that which are used by the flyte charts
    Haytham Abuelfutuh

    Haytham Abuelfutuh

    8 months ago
    Hey @Eugene Cha thanks for posting your question! Flyte, the product/services… etc. does work on 1.10+ of k8s… We’ve been updating the charts/kustomize/manifests as K8s APIs go deprecated/replaced… so you will find a chart/kustomize versions that work on any of these past versions of K8s… The current release of flyte helm charts (flyte v0.19.1) works on 1.17-1.21… There are a couple of K8s APIs related to ingresses that are going to be fully removed in 1.22. So this release will stop working for 1.22 but the new release v0.19.2 will… Unfortunately with how frequently APIs change in K8s, we couldn’t find the capacity to track every change and mark the releases appropriately… We can use some help tracking that if you’re interested 🙂